
LITA Summer School, Poznan 24th-28th June 2013

Introduction to Advanced Lidar Analysis

Table of Contents
Aims.....................................................................................................................................................2
Outcomes..............................................................................................................................................2
How to use this booklet........................................................................................................................2
Task 1 – Creating a GRASS location...................................................................................................3
Task 2 – Changing the GRASS Region................................................................................................8
Task 3 – Import the Lidar raster data to GRASS................................................................................18
Task 4 – Create a PCA model in GRASS...........................................................................................19
Task 5 – Create a SVF model in GRASS...........................................................................................25
Task 6 – Create an LRM in GRASS...................................................................................................33

Course Materials designed by Rebecca Bennett, June2013

Please use freely for your own information and the instruction of others but recognise the rights of
the author to be acknowledged if the material contained is disseminated. 

               LITA Lab 3 – Advanced Lidar Processing using GRASS
 1



LITA Summer School, Poznan 24th-28th June 2013

P  re-requisites  
You should have completed the tasks in workshop s 1 and 2 to be familiar with QGIS before beginning this 
workshop. You should also have read the technical papers introducing Local Relief Modelling (LRM) and the 
Sky View Factor (SVF).

Aims

The aim of this lab is familiarise yourself with advanced processing techniques fro lidar data using QGIS and 
GRASS GIS.

• set up a new project in GRASS (using the QGIS step by step guide)

• set the GRASS region (raster processing settings)

• create a SVF (horizon) model in GRASS

• create a local relief model in GRASS using custom commands

• export your work.

Each of these tasks stand alone as useful GIS tools but together they provide a workflow for advanced 
processing of lidar.

Outcomes

At the end of the lab you will submit a printed map of your LRM and SVF in pdf form to demonstrate your 
completion of the technical exercises.

How to use this booklet

Illustrations in this booklet show the icons on screen for each task. The full menu options are notated as 
follows:  File > Open.
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Task 1 – Creating a GRASS location
GRASS GIS is a very powerful opensource GIS software originally developed for the US Army. It features 
many high-level raster processing functions that do not exist in QGIS alone including the ability to create
LRM and SVF models and scripting of processes. GRASS has a reputation for having a steep learning 
curve, but fortunately you can use QGIS as a front-end to smooth the transition between the software.

1. Go to Go to Plugins> Manage Python Plugins. Ensure that “GRASS” has a check beside it to display the 
GRASS Toolbar.

2.  The first step is to create a GRASS Location, which is essentially a directory in which GRASS will store the 
raster and vector files you make for any project. The structure of this directory is very important and can
be fiddly to get right in GRASS itself – the QGIS plugin makes the process of establishing a location much 
easier and the location created can be used through the QGIS GRASS plug in or in GRASS alone. Click on 
the Create new mapset icon to open the window below:
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3. Browse to a directory in which to store your data. When using for the first time you should create a 
directory called “grassdata” to keep all your GRASS locations in. Click next. 

4. Select “create a new location”, give your location a name (with no spaces or special characters) 
and click next.
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5. We will now set the CRS for the GRASS location. You will see that the plugin suggests recently used 
systems at the bottom of the window. Select the OSGB36 CRS (using the same ESPG ID as before). Click 
next.

6. Set the Region of interest. This part is particularly important as GRASS only performs its operations 
within the bounds of this region of interest. For simplicity here select the current QGIS extent. Click set 
and the North, South, East and West bounds will change. Click next.
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7. Within the location create a mapset to work in. This could be the name of the processing e.g SVF. Click 
next.

8. The final screen confirms the location and mapset you have created. Click finish to return to the QGIS 
main screen. The mapset will now be open and the GRASS toolbar icons active.
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Task 2 – Changing the GRASS Region
The Region settings in GRASS control all the raster processing areas and resolutions. Before we can 
undertake any processing with the lidar data we need to amend the region to match our data.

1. To do this we will import the Area vector file we created in workshop one into the GRASS mapset 
and set the region to match it. First open your area shapefile.

2. On the GRASS tool bar select the GRASS tools icon.

3. In the Modules Tree tab navigate to File management > Import into GRASS > Import Vector into 
Grass > Import Loaded Vector. Click to open the tool.
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4. Select your vector file  (created in task 2) from the drop down menu. Give the GRASS vector you will
create a name (you may wish to prefix this with “GRASS” if you intend to use the same name as the 
original shapefile to denote that it is a GRASS vector e.g. GRASSarea). Click “Run” then “View 
Output” to add the GRASS vector to the navigation menu to the left of the QGIS screen.

5. You will see both the original and GRASS area vector in the QGIS view. Remember you can check the
source of a file by hovering your mouse over its name in the navigation bar. The symbology of the 
GRASS vector can be edited in the same way as for QGIS vectors (See task 2).
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6.

7. To set the region to match this vector select the GRASS tools Icon again and navigate to Region 
Settings > Set Region to match multiple vectors 

8. Type in the name of your vector file. Click Run and close.
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9. To make sure that the region is set, switch off both your area vector files in the layer manager and 
use the Display Current GRASS Region icon

10. A red line will now appear on your screen showing the extent of the current GRASS region. 
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11. The QGIS /GRASS toolbar gives only a selection of the most common GRASS functions. You can 
access all the GRASS functions by using the “GRASS shell” to enter commands. We will now use the 
GRASS shell within QGIS to check the resolution of the region. From the GRASS Tools window, click 
to open the GRASS shell.

12. In the shell window type g.region (the GRASS command for the region settings). Hit return. A new 
window will open.

               LITA Lab 3 – Advanced Lidar Processing using GRASS
 13



LITA Summer School, Poznan 24th-28th June 2013

13. To check your current settings switch to the “Print” tab and tick “Print the Current region”. Click 
Run.

14. The window will switch to the “Command Output” tab where the current region settings will be 
displayed. You will see that the resolution settings (nsres and ewres) are set to over 1m per pixel. As
the data we will be using is of 0.5m resolution we need to change this setting.
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15. In the “Existing” tab select your imported vector from the drop down menu.

16. In the “Resolution” tab enter the value 1 in the NS and EW grid resolution boxes. Click run.
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17. The module will switch to the “Command Output” tab where the new resolution settings will be 
displayed.

18. Close the window and the shell window to return to QGIS.
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Task 3 – Import the Lidar raster data to GRASS
1. Open GRASS Tools

2. Navigate to File Management >Import raster into GRASS> Import Raster into GRASS from QGIS 
view> r.ingdal – Import loaded raster.

3. Pick the lidar raster layer for import, give the GRASS output raster a name and check Override 
Projection. Click Run then View Output.

4. Your GRASS lidar raster will now be displayed in the QGIS window. Remove the non-grass lidar 
raster and area vector and save your project. Close QGIS
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Task 4 – Create a PCA model in GRASS
Now we have set up our GRASS project we will switch from QGIS to GRASS to create a PCA model of
the shaded relief models. 

1. Open GRASS from the desktop

2. You will need to navigate to the Location and Mapset you created in QGIS during the previous task. 
When you have browsed to the directory “grassdata” select the location then the mapset. Then 
click “Start GRASS”
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3. You may get a lock file warning. The lock file exists to prevent concurrent use of the same GRASS 
location by two different people, but when using the QGIS GRASS plugin the lock file is often not 
removed when QGIS is closed. It is safe to remove the lock file when you are the only person 
working on the location so click OK twice. 

4. Grass will then open two windows as shown below. On the left is the Map Display where graphics 
are displayed, to the right is the GIS or Layer Manager where layers are added and modified and 
where the menus are found for each function.

5. First we will add a vector and a raster to the display. In the GIS Manager click on the Add Vector Icon
in the same window and select the vector file representing the study area that you imported in Task
2 (Area).

6. Then click on the Add Raster icon and pick the lidar raster from the drop down menu.
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Your screen should now look something like the image below. 

7. Now we will create shaded relief models from the lidar data imported.  Got to Raster > Terrain 
Analysis shaded relief.
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8. In the Required tab pick your lidar raster from the drop down menu.

9. In the Optional tab enter the output file name, altitude, azimuth and z exaggeration. Use the visual 
comparisons from QGIS workshop 1 to select the “best” parameters. Click Run.

10. Without closing the window create 7 more shaded relief models at 45° intervals, keeping the same 
altitude and z exaggeration.
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11. Now we will perform a PCA analysis on the 8 shaded relief models. Go to Imagery > Transform > 
Principal Components

12. Add all 8 of your shaded relief files to the Input field. Give your output rasters a prefix. Click run.

13. Notice that the tool makes as many PCA images as original shaded relief images. Add your first PCA 
to the map display using the add raster icon, then add the others. Take a few minutes to compare 
the features visible in the different PCA images.
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14. We will now export the SVF map as a geotiff to view in any GIS software. Go to File > Export Raster 
Map > Common export formats [r.out.gdal]. In the Required tab pick the first PCA file and browse to
your directory to save the geotiff.
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Task 5 – Create a SVF model in GRASS

1. We will now use the r.horizon tool to create a SVF. To open the module navigate to Raster > Terrain 
Analysis > Horizon Angle [r.horizon].
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2. The r.horizon tool works in two modes, as explained in the header to the tool. To create an SVF 
model we use the second mode. In the Required tab pick your lidar raster as the input.

3. We will compute 8 models at 45° intervals starting at 0. The step size will be 30 to match the 
published work. Enter the parameters on the Input_options tab as show below.
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4. In the Output_options tab enter the prefix of the output maps and click run.

5. The tool will switch to the Command output tab to show you the progress of the processing. 
Depending on the speed of your processor this may take some time.  Note the command input is 
displayed at the base of the tool GUI. You can use this on its own to create the models from the 
Layer Manager window.
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6. When the process is complete we will have created 8 rasters of incident light that we need to 
average into an SVF model. To do this we will use the r.mapcalc tool. Go to Raster > Raster Map 
Calculator [r.mapcalc]

7. Enter the name of the output raster. Remember to include the processing options in the file name 
as we did with the hillshade models.

Add the expression in the Expression window using the Insert existing raster map drop down to add
your SFV rasters. There should be no spaces between the raster names and the operand (+).
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8. We can change the display of the raster to greyscale. Right-click on the raster in the layer menu and 
select Set Color Table

9. On the colours tab select histogram equalisation and pick a grey colour table. Click Run to view the 
result
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10. We will now export the SVF map as a geotiff to view in QGIS. Go to File > Export Raster Map > 
Common export formats [r.out.gdal]. In the Required tab pick the SVF file and browse to your 
directory to save the geotiff.

11. In the  Options tab you will see that there are lots of output formats. Select Gttiff.
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12. Open QGIS and add the SVF geotiff.
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Task 6 – Create an LRM in GRASS
We can also use GRASS to create a local relief model. This process has many steps, including raster and 
vector processing be sure to work through each carefully and in order.

Preparation

1. First we will connect to a database to store our vector files. In the Layer Manager go to Database > 
Manage Databases > Connect

2. Select sqlite as the database format and name your database, (don't forget the .db at the end!). Click 
Run then Close.
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3. Now we will check our region settings. Go to Settings > Region > Display Region. The layer 
manager will switch to the command window and display the region parameters. Check the extent 
and resolution.

Create the LRM

1. First make a copy of the lidar DSM to work with. We can use the command console to access any 
tools' GUI so in the console type g.copy and hit return twice. Click Run.
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2. In the g.copy window type the name of your lidar DSM followed by a comma then the new name 
“ground” e.g. lidar,ground

3. Now we will perform the low pass filter. Go to to your command console and type r.mfilter. Hit 
return twice.

4. Select ground as your input map, name your output map LRM_lowpass. Grass uses a text file to 
undertake the filter (see the detail format specification here: ). Navigate to the filter files folder on 
the z drive and select the 9m filter. Click Run. The lowpass filtered raster will be shown in the 
display.
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5. Now we will take the lowpass filter from the ground raster. Go to Raster > Raster Map Calculator

Name your new map LP_subtract and add the expression ground@lidar – LRMlowpass@lidar. Click
run,

6. Extract the zero contours from the LP_subtract raster. Go to Raster > Generate contour lines.

In the Required tab add LP_subtract as the input raster and name your output vector LP_contours.
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7. In the optional tab set your min and max levels to 0 and your step size to 10. Click Run.

8. Now convert your contour lines into points. Go to Vector > Generate points > Generate points along 
lines. Add LP_contours and name your output LP_contours_points
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9. In the Optional tab de select point, boundary and centroid to leave only line. Set a maximum distance
of 10. Click run. This process may take a few minutes – be patient!

10. Now we will add a column to the point data in the database in order to store a height value extracted 
from the ground raster. Go to Database > Vector database connections > Add columns

In the Required tab, pick your point map LP_contours_points

Add a column called height with a type double.
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11. In the Options tab select layer 2. Click Run.

12. Now we will extract the raster values to the points vector. Go to Vector >  Update point attributes 
from raster > sample raster at point locations.

In the required tab add the LP_contours_points as your input, ground as the raster to be queried and 
column as height.

13. In the optional tab select layer 2. Click Run.

14. Now we have the final stage of interpolating the purged model. This can take some time depending 
on the size of your data and speed of your processor, so be patient!

Go to Raster > Interpolate raster from vector points > bilinear and bicubic from vector points

In the Required tab add the LP_contours_points vector

In the Settings tab select layer 2 and the height column.

In the Optional tab add the name of your output raster: Purged

Click Run. Go make some tea.
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15. The final stage of the process is to subtract the purged model from the original DTM. using 
r.mapcalc.

16. When the LRM is finished processing, change the colour table to greyscale and export the LRM to a 
geotiff to view in QGIS.
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